<div dir="ltr">Hi,<div><br></div><div>Some new C files in (say) fileio and timing modules have underscores. The new C++ files tend to be named according to a major class that they implement, which are also not named with delimiters. Not needing to interrupt keyboard flow with shift-minus is a small advantage, but I would prefer readability over that! Different people&#39;s brains work differently, too!<div>
<br></div><div>I&#39;m happy with any name so long as un-delimited concatenation is at most about three words (for readability), and does not prefix gmx or a module name without due reason. For example, gmxassert.h is fine (to avoid ambiguity with assert.h), but my perfect world would not have files with repetitive names like</div>
</div><div><br></div><div>src/gromacs/gmxlib/nonbonded/nb_kernel_avx_256_single/nb_kernel_template_avx_256_single.pre</div><div><br></div><div>I&#39;d prefer names like</div><div><br></div><div>src/gromacs/groupkernels/avx_256_single/template.pre<br>
</div><div><br></div><div>but people editing multiple template.pre files might not like that. How much of a problem do people have with CMakeLists.txt files? I solve that one with</div><div><br></div><div><div>(require &#39;uniquify)</div>
<div>(setq uniquify-buffer-name-style &#39;reverse)</div></div><div><br></div><div>in my .emacs file. So when I have multiple such files open, I have to switch buffers between CMakeLists.txt/gromacs and CMakeLists.txt/mdlib. That works fine for me - and there&#39;s no penalty when there&#39;s only one such file open.</div>
<div><br></div><div>Mark</div><div><br></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Thu, Nov 28, 2013 at 8:04 PM, Szilárd Páll <span dir="ltr">&lt;<a href="mailto:pall.szilard@gmail.com" target="_blank">pall.szilard@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi,<br>
<br>
It has recently come up that the direction 5.0 is moving toward is no<br>
delimiters in file names, i.e. no underscores.<br>
<br>
I personally think no delimiters is detrimental (unless one uses DOS).<br>
Just compare the readability of<br>
gmx_detect_hardware.c vs gmxdetecthardware.c<br>
or<br>
nbnxn_cuda_kernel_utils.cuh vs nbnxncudakernelutils.cuh<br>
<br>
I&#39;m not saying that somebody should change/fix this ASAP, but it may<br>
be worth considering whether this is really what we want.<br>
<br>
Cheers,<br>
--<br>
Szilárd<br>
<span class="HOEnZb"><font color="#888888">--<br>
Gromacs Developers mailing list<br>
<br>
* Please search the archive at <a href="http://www.gromacs.org/Support/Mailing_Lists/GMX-developers_List" target="_blank">http://www.gromacs.org/Support/Mailing_Lists/GMX-developers_List</a> before posting!<br>
<br>
* Can&#39;t post? Read <a href="http://www.gromacs.org/Support/Mailing_Lists" target="_blank">http://www.gromacs.org/Support/Mailing_Lists</a><br>
<br>
* For (un)subscribe requests visit<br>
<a href="https://maillist.sys.kth.se/mailman/listinfo/gromacs.org_gmx-developers" target="_blank">https://maillist.sys.kth.se/mailman/listinfo/gromacs.org_gmx-developers</a> or send a mail to <a href="mailto:gmx-developers-request@gromacs.org">gmx-developers-request@gromacs.org</a>.<br>

</font></span></blockquote></div><br></div>